[ Home ] [ << Older entry ] [ Newer entry >> ]

ELENA Issues with https connection - only http will work ...

SAP and ZSS are having some issues with the https connection since changes on the ZSS site. The complete root cause seems to be not really clear. Now, http only is supported for customers.
This does NOT mean, that it would be no longer safe to use this connection. The encryption happens on the application layer then, which is fully sufficient - just different ...

At least the following notes are of interest in this area:

Note 1448193 - ELENA: Set up HTTP connection for communication server

Note 1459401 - ELENA: HTTP correction for confirm

Note 1460897 - ELENA: File no. error in test run RPCELKD0 w/ several files

Note 1472232 - ELENA: Problems during transfer via HTTPS

Note 1472232 describes the root cause in the following dev_icm trace more in detail:

[Thr 5] *** ERROR during SecudeSSL_SessionStart() from SSL_connect()==SSL_ERROR_SSL
[Thr 5] session uses PSE file "/usr/sap/....xypDSRV.pse"
[Thr 5] SecudeSSL_SessionStart: SSL_connect() failed
secude_error 536875072 (0x20001040) = "received a fatal SSLv3 handshake failure alert message from the peer"
[Thr 5] >> Begin of Secude-SSL Errorstack >>
[Thr 5] WARNING in ssl3_read_bytes: (536875072/0x20001040) received a fatal SSLv3 handshake failure alert message from the peer
[Thr 5] << End of Secude-SSL Errorstack
[Thr 5] SSL_get_state() returned 0x000021d0 "SSLv3 read finished A"
[Thr 5] No certificate request received from Server
[Thr 5] SSL NI-sock: local=xx.xx.xxx.x:xxxxx peer=xxx.xxx.x.xx:xxxx
[Thr 5] <<- ERROR: SapSSLSessionStart(sssl_hdl=0x5cd1900)==SSSLERR_SSL_CONNECT
[Thr 5] *** ERROR => IcmConnInitClientSSL: SapSSLSessionStart failed (-57): SSSLERR_SSL_CONNECT {00003277} [icxxconn_mt.c 2012]

[ go to top ] [ << Older entry ] [ Newer entry >> ]


back 12/11/2017, 04:57:19